Oxybul-Okaïdi BE orders are failing
Incident Report for Runa
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 14:44 UTC
Investigating
We are currently investigating an issue causing some orders of Oxybul-Okaïdi BE (OXYBUL-BE) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Nov 02, 2024 - 10:22 UTC
This incident affected: Gift Processing.