IKEA ES orders are failing
Incident Report for Runa
Resolved
This incident has been resolved.
Posted May 31, 2023 - 16:19 UTC
Investigating
We are currently investigating an issue causing some orders of IKEA ES (IKEA-ES) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted May 31, 2023 - 14:13 UTC
This incident affected: Gift Processing.