STEAM MX orders are failing
Incident Report for Runa
Resolved
This incident has been resolved.
Posted Nov 15, 2024 - 11:33 UTC
Investigating
We are currently investigating an issue causing some orders of STEAM MX (STEAM-MX) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Nov 05, 2024 - 12:34 UTC
This incident affected: Gift Processing.