Giant Eagle Express®stores US orders are failing
Incident Report for Runa
Resolved
This incident has been resolved.
Posted Jul 24, 2024 - 14:22 UTC
Investigating
We are currently investigating an issue causing some orders of Giant Eagle Express®stores US (GIANTX-US) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Jul 23, 2024 - 15:18 UTC
This incident affected: Gift Processing.