Prouds the Jewellers AU orders are failing

Incident Report for Runa

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 21:44 UTC

Investigating

We are currently investigating an issue causing some orders of Prouds the Jewellers AU (PROD-AU) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Mar 25, 2025 - 04:24 UTC
This incident affected: Gift Processing.