IKEA CA orders are failing
Incident Report for Runa
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 17:30 UTC
Investigating
We are currently investigating an issue causing some orders of IKEA CA (IKEA-CA) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Mar 19, 2024 - 17:11 UTC
This incident affected: Gift Processing.