YELMO ES orders are failing
Incident Report for Runa
Resolved
This incident has been resolved.
Posted Jan 28, 2025 - 17:24 UTC
Investigating
We are currently investigating an issue causing some orders of YELMO ES (YELMO-ES) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Dec 27, 2024 - 13:32 UTC
This incident affected: Gift Processing.