Steam (US Account) AE orders are failing
Incident Report for Runa
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 14:57 UTC
Investigating
We are currently investigating an issue causing some orders of Steam (US Account) AE (STEA-AE) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Oct 14, 2024 - 16:27 UTC
This incident affected: Gift Processing.