Amazon.de orders are failing
Incident Report for Runa
Monitoring
The merchant has notified us that orders should now process as normal. We will continue to monitor the situation.
Posted Jul 02, 2024 - 13:26 UTC
Investigating
We are currently investigating an issue causing some orders of Amazon.de (AMZ-DE) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Jun 17, 2024 - 14:37 UTC
This incident affects: Gift Processing.