Xbox CA orders are failing
Incident Report for Runa
Update
We are continuing to investigate this issue.
Posted May 17, 2024 - 10:45 UTC
Investigating
We are currently investigating this issue.
Posted May 17, 2024 - 10:44 UTC
This incident affects: Gift Processing.