Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 25, 2025 - 19:30 UTC
Scheduled
The Reserve Bank of India has established comprehensive guidelines for disaster recovery and business continuity planning for financial institutions. These regulations mandate that banks and NBFCs maintain robust IT infrastructure management, emphasizing disaster recovery and business continuity plans to ensure operational resilience during disruptions.
Key RBI requirements include: - Regular disaster recovery testing and validation - Comprehensive business continuity frameworks - Documented recovery strategies and procedures - Periodic review of IT-related risks and disaster recovery capabilities
As a result of this, the provider for IN products will be running this exercise this week:
*Implementation Timeline* Execution Dates: June 25th, 2025 Duration: 4 hours per execution Impact: Some orders for IN Products may fail during maintenance window, with full service restoration expected within the specified timeframe. All failed orders can be retried after the maintenance window
Posted Jun 25, 2025 - 13:28 UTC
This scheduled maintenance affected: Gift Processing.