Expected partial delays due to maintenance at 19th November 2024 05:00
Incident Report for Runa
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 15:01 UTC
Monitoring
Planned maintenance at Tuesday 19th November 2024 05:00. Expected delays for the following products: B&M UK, Greggs UK, Hobbycraft UK, Love2Shop Holidays UK, Matalan UK, National Garden UK, New Look UK, Pizza Express UK
Posted Nov 18, 2024 - 09:50 UTC
This incident affected: Gift Processing.