Microsoft Xbox Game Pass Ult 1M ESD NO orders are failing

Incident Report for Runa

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 10:52 UTC

Monitoring

We believe the product is now working as expected, and have re-enabled it in our catalog. We will be monitoring closely for further issues and will update here accordingly.
Posted Apr 14, 2025 - 09:52 UTC

Investigating

We are currently investigating an issue causing some orders of Microsoft Xbox Game Pass Ult 1M ESD NO (MSGU1-NO) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Apr 12, 2025 - 21:06 UTC
This incident affected: Gift Processing.