We believe the product is now working as expected, and have re-enabled it in our catalog. We will be monitoring closely for further issues and will update here accordingly.
Posted Nov 18, 2024 - 12:00 UTC
Investigating
We are currently investigating an issue causing some orders of PlayStation BE (PLAY-BE) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Nov 16, 2024 - 21:49 UTC
Monitoring
We believe the product is now working as expected, and have re-enabled it in our catalog. We will be monitoring closely for further issues and will update here accordingly.
Posted Nov 16, 2024 - 21:49 UTC
Investigating
We are currently investigating an issue causing some orders of PlayStation BE (PLAY-BE) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.