Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 18, 2025 - 09:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 17, 2025 - 13:13 UTC
Scheduled
Scheduled - Due to an upstream provider maintenance, orders for some products (list provided below) may fail intermittently during these windows: From: Wednesday, November 18 - 09:00 UTC To: Wednesday, November 18- 11:00 UTC
🛠️ Affected Products
Below is the complete list of products that may experience intermittent issues during the maintenance window.
1-800-PetSupplies US Ace Hardware US Aerie US Aéropostale US Albertsons [Heart] US AMC® Theatres US American Eagle US American Cancer Society US Great American Days US American Red Cross US Amtrak US Ann Taylor US Applebee’s ® Apple CA Aquarium US Baby Depot at Burlington US Bakers Square US Barnes & Noble US Bass Pro Shops US Babylist US Burger King US Blizzard CA Bob Evans Restaurants® US Baskin Robbins US Burlington US Cabela's CA Cabela's US Carnival Cruise Lines US CanvasPop US CDC Foundation US Champs Sports US Chico's US Chipotle US Charity on Top US Celebrity Cruises US Clean Water Fund US Candy Crush US Cost Plus World Market US Crutchfield US Dave & Buster's US Delta US Dick's Sporting Goods US Dunkin’ US EA Play US Equal Justice Initiative US East Side Mario’s CA Fairmont Hotels & Resorts Famous Dave’s® US Fanatics CA Foodland CA Foot Locker US FreshCo CA Gander Outdoors US GCodes® Global Everything US GCodes® Global Experiences US GCodes® Global Merchandise US GCodes® Global Digital Media US GCodes® Global Retail US GCodes® Global Hotel & Travel US GLAAD US Guild Wars 2 Gem Card US Go Play Golf by Fairway Rewards US Groupon US Guitar Center US Girls Who Code US Hard Rock Cafe US Harvey’s CA Hotels.com US Homegoods US Hope For Ukraine US HULU US iFLY US IHOP US IKEA CA Jersey Mike's US Kigso CA LaGriglia US La Maison Simons CA Land's End US Lawtons CA Logan's Roadhouse US L.L. Bean US Lane Bryant US Lowe's US LUSH CA Lyft CA Lyft US Marshalls US Microsoft 365 Family US Microsoft 365 Business Standard US Microsoft 365 Personal US Mandarin Oriental Hotel Group US Montanas CA maurices US Marriott US Mark & Graham US Mastercard® Prepaid eReward Card, 12 Month Expiration CA Nascar.com US The Nature Conservancy US National Park Foundation US Nautica US New York Fries CA Nexon Game Card CA Nintendo eShop CA Nintendo eShop US Nexon Karma Koin US Original Joe's CA Bed Bath & Beyond US Panda Express US Paramount+ US Pottery Barn Teen US Peet's Coffee US PetSmart US Pilot Flying J US Pickle Barrel CA Penningtons Reitmans RW & CO CA Pinkberry® US Pottery Barn US QuickGifts Card Mall dibbs US P.C. Richard and Son US Reitman's CA Restaurant.com US Rubio’s Coastal Grill US RW & Co CA Razer Gold CA Albertson's/Safeway US Saks Fifth Avenue US Sheetz US Sierra US San Luis Resort US Sobeys CA Sobeys - CA Soma US PlayStation Store CA Special Olympics US Sporting Life CA State Main CA Subway CA Subway US Safeway CA sweetFrog® US Swissôtel Hotels & Resorts US Texas Roadhouse US TIDAL US Tijuana Flats US TJ Maxx US Tot Squad - Breastfeeding Help US Tot Squad - Car Seat Safety US Tot Squad - Child Nutrition US Tot Squad - Sleep Coaching US Tot Squad US TQ Game Card CA Unicef US UNTUCKit US Victoria's Secret PINK US Victoria's Secret US Visa® Reward Virtual Account, 12 Month Expiration US Visa® Reward Virtual Account, 6 Month Expiration CA Visa® Reward Virtual Account, 6 Month Expiration US The Vitamin Shoppe® US Village Inn US World of Warcraft CA Wayfair CA Walgreens US White House Black Market US Williams-Sonoma US Walmart CA West Elm US Xbox Game Pass Ultimate 1 Month CA Xbox Game Pass Ultimate 3 Month CA Your Gift Choice US
Posted Nov 17, 2025 - 13:12 UTC
This scheduled maintenance affected: Gift Processing.