Petco US orders are failing
Incident Report for Runa
Resolved
This incident has been resolved.
Posted Oct 11, 2024 - 01:38 UTC
Investigating
We are currently investigating an issue causing some orders of Petco US (PETCO-US) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Oct 10, 2024 - 23:36 UTC
This incident affected: Gift Processing.