adidas ES orders are failing
Incident Report for Runa
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 08:47 UTC
Investigating
We are currently investigating an issue causing some orders of adidas ES (ADAS-ES) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted May 31, 2023 - 18:16 UTC
This incident affected: Gift Processing.