TK Maxx Employee Benefits UK orders are failing

Incident Report for Runa

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 17:03 UTC

Investigating

We are currently investigating an issue causing some orders of TK Maxx Employee Benefits UK (TKMXEB-GB) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted Apr 02, 2025 - 16:45 UTC
This incident affected: Gift Processing.