PlayWood IT orders are failing
Incident Report for Runa
Resolved
We regret to inform you that we have made the decision to discontinue this product and, as a result, it will no longer be available in our catalogue. We sincerely apologize for any inconvenience this may cause.
Posted Oct 03, 2024 - 09:40 UTC
Investigating
We are currently investigating an issue causing some orders of PlayWood IT (PLAY-IT) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted May 13, 2024 - 19:57 UTC
This incident affected: Gift Processing.