Plantagen SE orders are failing
Incident Report for Runa
Resolved
This incident has been resolved.
Posted May 31, 2023 - 15:46 UTC
Investigating
We are currently investigating an issue causing some orders of Plantagen SE (PLNTGN-SE) e-gifts to fail. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Posted May 26, 2023 - 16:45 UTC
This incident affected: Gift Processing.